MirBSD manpage: bce(4)
BCE(4) BSD Programmer's Manual BCE(4)
bce - Broadcom BCM4401 Ethernet device driver
bce* at pci? dev ? function ?
The bce provides support for the Broadcom BCM4401 10/100 Ethernet card.
Other cards from the 440x series may also be supported.
The following media types and options (as given to ifconfig(8)) are sup-
ported:
media autoselect
Enable autoselection of the media type and options (default).
media 100baseTX mediaopt full-duplex
Set 100Mbps (Fast Ethernet) operation and force full-duplex
mode.
media 100baseTX mediaopt half-duplex
Set 100Mbps (Fast Ethernet) operation and force half-duplex
mode.
media 10baseT mediaopt full-duplex
Set 10Mbps operation and force full-duplex.
media 10baseT mediaopt half-duplex
Set 10Mbps operation and force half-duplex.
If no media options are present, the bce driver places the card into au-
toselect mode.
bce%d: failed to enable memory mapping! A fatal initialization error has
occurred.
bce%d: unable to find mem space A fatal initialization error has oc-
curred.
bce%d: unable to wake up from power state D%d The card has lost its con-
figuration data during power save mode.
bce%d: couldn't map interrupt A fatal initialization error has occurred.
bce%d: couldn't establish interrupt A fatal initialization error has oc-
curred.
bce%d: unable to alloc space for ring descriptors, error = %d A fatal
initialization error has occurred.
bce%d: unable to map DMA buffers, error = %d A fatal initialization er-
ror has occurred.
bce%d: unable to create ring DMA map, error = %d A fatal initialization
error has occurred.
bce%d: unable to create tx DMA map, error = %d A fatal initialization
error has occurred.
bce%d: unable to create rx DMA map, error = %d A fatal initialization
error has occurred.
bce%d: Tx packet consumes too many DMA segments, dropping... An outgoing
packet didn't fit in the allocated number of segments.
bce%d: unable to load Tx buffer, error = %d Short on resources when
transmitting a packet, it will be retried later.
bce%d: device timeout The device has stopped responding to the network
or there is a problem with the network connection (cable).
bce%d: transmit fifo underflow An error occurred, the interface will be
reinitialized.
bce%d: receive fifo overflow An error occurred, the interface will be
reinitialized.
bce%d: receive descriptor underflow An error occurred, the interface
will be reinitialized.
bce%d: descriptor protocol error An error occurred, the interface will
be reinitialized.
bce%d: data error An error occurred, the interface will be reinitial-
ized.
bce%d: descriptor error An error occurred, the interface will be reini-
tialized.
bce%d: general purpose timeout An error occurred, the interface will be
reinitialized.
bce%d: unable to allocate or map rx(%d) mbuf, error = %d Failed to ini-
tialize the interface.
bce%d: timed out writing pkt filter ctl Failed to add MAC address.
bce%d: timed out disabling ethernet mac A problem occurred when reset-
ting the interface.
bce%d: receive dma did not go idle after error A problem occurred when
resetting the interface.
bce%d: timed out resetting ethernet mac A problem occurred when reset-
ting the interface.
bce%d: while resetting core, reject did not set A problem occurred when
resetting the interface.
bce%d: while resetting core, busy did not clear A problem occurred when
resetting the interface.
bce%d: PHY read timed out reading phy %d, reg %d, val = %x An error oc-
curred when reading a PHY register on the MII.
bce%d: PHY read timed out writing phy %d, reg %d, val = %x An error oc-
curred when writing a PHY register on the MII.
bge(4), mii(4), pci(4), ukphy(4)
The bce driver appeared in NetBSD 1.6.2. OpenBSD support was added in
OpenBSD 3.5
The bce driver was written by Cliff Wright <cliff@snipe444.org> and port-
ed to OpenBSD by
Nathan L. Binkert <binkertn@umich.edu>.
MirBSD #10-current September 28, 2003 1