MirBSD manpage: disktab(5)

DISKTAB(5)                   BSD Reference Manual                   DISKTAB(5)

NAME

     disktab - disk description file

SYNOPSIS

     #include <disktab.h>

DESCRIPTION

     disktab is a simple database which describes disk geometries and disk
     partition characteristics. It is used to initialize the disk label on the
     disk. The format is patterned after the termcap(5) terminal database. En-
     tries in disktab consist of a number of colon (':') separated fields. The
     first entry for each disk gives the names which are known for the disk,
     separated by "|" characters. The last name given should be a long name
     fully identifying the disk.

     The following list indicates the normal values stored for each disk en-
     try:

     Name      Type     Description
     ty        str      Type of disk (e.g., removable, winchester).
     dt        str      Type of controller (e.g., SMD, ESDI, floppy).
     ns        num      Number of sectors per track.
     nt        num      Number of tracks per cylinder.
     nc        num      Total number of cylinders on the disk.
     sc        num      Number of sectors per cylinder (default: ns*nt).
     su        num      Number of sectors per unit (default: sc*nc).
     se        num      Sector size in bytes (default: DEV_BSIZE).
     sf        bool     Controller supports bad144-style bad sector
                        forwarding.
     rm        num      Rotation speed in RPM (default: 3600).
     sk        num      Sector skew per track (default: 0).
     cs        num      Sector skew per cylinder (default: 0).
     hs        num      Headswitch time in usec (default: 0).
     ts        num      One-cylinder seek time in usec (default: 0).
     il        num      Sector interleave (n:1) (default: 1).
     d[0-4]    num      Drive-type-dependent parameters.
     b0        str      Pathname to primary bootstrap.
     b1        str      Pathname to secondary bootstrap.
     bs        num      Boot block size (default: BBSIZE).
     sb        num      Superblock size (default: SBSIZE).
     ba        num      Block size for partition "a" (bytes).
     bd        num      Block size for partition "d" (bytes).
     be        num      Block size for partition "e" (bytes).
     bf        num      Block size for partition "f" (bytes).
     bg        num      Block size for partition "g" (bytes).
     bh        num      Block size for partition "h" (bytes).
     fa        num      Fragment size for partition "a" (bytes).
     fd        num      Fragment size for partition "d" (bytes).
     fe        num      Fragment size for partition "e" (bytes).
     ff        num      Fragment size for partition "f" (bytes).
     fg        num      Fragment size for partition "g" (bytes).
     fh        num      Fragment size for partition "h" (bytes).
     oa        num      Offset of partition "a" (sectors).
     ob        num      Offset of partition "b" (sectors).
     oc        num      Offset of partition "c" (sectors).
     od        num      Offset of partition "d" (sectors).
     oe        num      Offset of partition "e" (sectors).
     of        num      Offset of partition "f" (sectors).
     og        num      Offset of partition "g" (sectors).
     oh        num      Offset of partition "h" (sectors).
     pa        num      Size of partition "a" (sectors).
     pb        num      Size of partition "b" (sectors).
     pc        num      Size of partition "c" (sectors).
     pd        num      Size of partition "d" (sectors).
     pe        num      Size of partition "e" (sectors).
     pf        num      Size of partition "f" (sectors).
     pg        num      Size of partition "g" (sectors).
     ph        num      Size of partition "h" (sectors).
     ta        str      Type of partition "a" (4.2BSD, swap, etc.).
     tb        str      Type of partition "b".
     tc        str      Type of partition "c".
     td        str      Type of partition "d".
     te        str      Type of partition "e".
     tf        str      Type of partition "f".
     tg        str      Type of partition "g".
     th        str      Type of partition "h".

FILES

     /etc/disktab

SEE ALSO

     getdiskbyname(3), disklabel(5), disklabel(8), newfs(8)

HISTORY

     The disktab description file appeared in 4.2BSD.

MirBSD #10-current               June 5, 1993                                1

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung